This document is a quick usage overview. By default the kit will reset the server password to Password01 as documented in the TLG.

The lab is built using the design in the Test Lab Guide: Base Configuration.

The tool will build your fully functional Test Lab allowing you to focus on your actual project that you may find in the Test Lab Guide Wiki.

 

Here’s a quick walkthrough. Once the ISO is inserted into a server, you will get the autorun prompt.

 

The first screen is the server selection screen. Click next.

Each server has it’s own unique configuration wizard pane. This will allow you to use your own custom naming standards and IP address scopes etc. The defaults will build the standard Contoso domain as detailed in the TLG guides. Accept the defaults and click next.

You will see a confirmation pane allowing you to review the configuration settings before deployment. Click Begin.

The Hydration process will begin, rebooting as needed.

When finished you will be presented with a final summary page.

 

You’re then able to repeat the process for the next server. Please post any issues/bugs here on Codeplex. and I will address them.

Last edited Feb 24, 2013 at 9:32 PM by Scriptimus, version 4

Comments

binaryman1 Nov 5, 2015 at 1:18 AM 
Hello, I hope that someone out there can help. I have struggled with this lab off and on, between all the other %^#&&@ you have to do in life. At this point I have the ISO mounted on a VM Server 2008 R2 that I am calling "Hydration". I got the list of VMs I can create with the hydration kit and chose 'DC1'. It reached the end of the creation of DC1 and it looks like it worked correctly, but I look at the Group I created for the "Hydration" VM server in Virtual Box and "Hydration" is the only VM listed. I check the info for the setup of the DC1 VM that I just ran from the ISO and it says 'Server Manager (DC1) but I do not understand how to "save" this DC server and then go back to use the ISO to create the other machines. What is the next step? On page https://testlabhydrationkit.codeplex.com/wikipage?title=Using%20the%20Hydration%20Kit%20-%20Test%20Lab%3a%20Base%20Configuration%20for%20Windows%20Server%202008%20R2&referringTitle=Quick%20Start%20-%20Test%20Lab%3a%20Base%20Configuration%20for%20Windows%20Server%202008%20R2 it says 'When finished you will be presented with a final summary page.' Then it says 'You’re then able to repeat the process for the next server. Please post any issues/bugs here on Codeplex. and I will address them.' . Well, How do I repeat the process and how do I save the result of the first time through the process???" Please Help.

binaryman1 Nov 28, 2014 at 5:00 PM 
Per the downloaded lab creation instructions: INET1 (PAGE 32) ip specs are : IP address: 10.0.0.1
Subnet mask: 131.107.0.1
No default gateway
Connection specific DNS suffix: isp.example.com

The server or router it is connected to has ip instructions: EDGE1 (PAGE 31)

TCP/IP configuration on the Corpnet subnet network adapter:

IP address: 10.0.0.2
Subnet mask: 255.255.255.0
DNS server: 10.0.0.1
No default gateway
Connection specific DNS suffix: corp.contoso.com

TCP/IP configuration on the Internet subnet network adapter
IP address: 131.107.0.2 and 131.107.0.3
Subnet mask: 255.255.255.0
No default gateway
Connection specific DNS suffix: isp.example.com

THAT first subnet mask looks a little suspicious.


Also when trying to download using the scripts in Powershell, here is what I get for one of them:

PS C:\WINDOWS\system32> .\Get-Software.ps1
.\Get-Software.ps1 : The term '.\Get-Software.ps1' is not recognized as the name of a cmdlet, function, script file,
or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and
try again.
At line:1 char:1
+ .\Get-Software.ps1
+ ~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (.\Get-Software.ps1:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

DeploywindowsNet Jan 25, 2013 at 4:56 PM 
Awesome, Great Kit /Lars, DeployWindows.net